ABSTRACT

SAS/GRAPH® ODS Graphics Editor is an interactive GUI-based tool for editing and customizing plots created by the ODS Graphics system. With SAS 9.2, many SAS analytical procedures automatically create graphical output. This video poster will demonstrate how you can edit and customize visual aspects of an output graph with this interactive tool. We will edit the title, add a footnote, reposition the legends, and change marker and line attributes. We will add free-form annotation to highlight the results in the plot. Finally, we will use the data label management facility to control the specific data labels that are shown in the plot. The ODS Graphics Editor is particularly useful for making specific changes, highlighting outliers, or touching up a graph before publishing. The changes are saved with the edited graph, but they are not persisted if the original code is rerun.

INTRODUCTION

The ODS Graphics system is an extension to ODS and is available with SAS 9.2. With this system, you can get modern analytical graphics produced automatically by many SAS procedures by using the statement ODS GRAPHICS ON;: As part of the ODS Graphics system, SAS/GRAPH ships the Graph Template Language (GTL) syntax for defining sophisticated analytical graphs using the TEMPLATE procedure. Four new SAS/GRAPH procedures are included to create commonly used analytical graphs. The ODS Graphics Editor is included with SAS/GRAPH for interactively editing and customizing ODS graphics output from the procedures.

The graphs that are automatically produced by the procedures are based on GTL. To customize the ODS graphics output, you need to edit the associated template or program, and resubmit it to get the customized output. For many users who want to make minor changes to the graphs, this can be an onerous task, and the ODS Graphics Editor can come to the rescue. The Editor provides an interactive GUI to make such changes easy. Using the GUI, you can change the graph style and the graph size. You can edit, add, or delete titles and footnotes, reposition the legends, and customize the visual properties of the plots and axes. Furthermore, you can add free-form annotation to the graph to emphasize the relevant aspects of the results. You can directly copy the customized graph to the system clipboard to include it in other documents, or save the graph for future use.

The ODS Graphics Editor is available to SAS users as a free download for use on workstations where SAS is not licensed. When graphical output has to be included in publications and presentations, the analysts or statisticians can make the output available to the publications staff, who can then customize the output using the stand-alone ODS Graphics Editor.

EDITABLE GRAPHS

When running SAS in DMS mode, the output from the procedures is listed in the Results window in a tree structure. In Figure 1, output files from PROC ROBUSTREG are listed. The ODS graphics files that are created for the Listing destination are represented by this icon  .

To view the graph as an image, double-click on the icon. By default, the ODS graphics output created by the procedure is not editable because creating editable output consumes system resources. In batch mode execution, where a large number of graphs are being created and do not need editing, using these system resources can be unjustified.

To be able to edit ODS graphics output using the ODS Graphics Editor, you need to enable the creation of editable graphs. This is done by submitting the command SGEDIT ON in the Results window. A note is shown in the status bar indicating that you can now edit graphics as shown in Figure 1. From this point on, ODS graphics created in the Listing destination will be editable. This setting is saved in the user preferences for future use.
To edit one of the graphs, click with the right mouse button and select **Edit** as shown in Figure 2. The ODS Graphics Editor is displayed in a separate window with the selected graph loaded.

**EDITOR WINDOW**
The ODS Graphics Editor window is shown in Figure 3. The name of the graph to be edited is displayed in the window title. The current size of the graph is displayed. In this case, the width is 640 pixels and the height is 480 pixels.

The ODS Graphics Editor provides tools to:

1. **Edit the graph.**
   a. Customize overall graph properties such as graph style and graph size and resolution.
   b. Edit, add, or delete titles and footnotes and adjust the legend position and properties.
   c. Customize the plot attributes such as plot background, marker color, size, text fonts, and so on.

2. **Annotate the graph.**
   a. Add annotation objects such as text, shapes, lines, arrows, and markers.
   b. Add image icons.
TOUR OF THE ODS GRAPHICS EDITOR

The ODS Graphics Editor provides various tools to edit and annotate the graph. The standard File menu provides menu items for file management and printing. The standard Edit menu provides a menu item to undo, menu items to cut, copy, and paste annotation objects, and a menu item to copy the graph to the system clipboard. The standard View menu enables you to show or hide the various menus, and to zoom on the display of the graph.

INSERT MENU

The Insert menu enables you to insert graph and annotate objects in the graph as shown in Figure 4.

Graph Objects are added at the top or bottom of the existing graph, and cause the plot area to resize.
- Titles are added at the top of the graph, below any existing titles.
- Footnotes are added at the bottom of the graph, below any existing footnotes.

Annotation objects are added in a layer on top of the graph and do not cause the plot area to resize. Annotation objects can be:
- text
- lines and arrows
- shapes
- image icons and markers

ARRANGE MENU

All annotation objects are drawn on top of the graph in the order they are initially created, with the last one drawn on top. The Arrange menu, shown in Figure 5, provides features to manage these annotation objects:
- Grouping enables you to select objects to be grouped together for subsequent actions, such as Move.
- Order enables you to specify the stacking order for the objects.
- Align enables you to position the selected objects to be aligned with the first object in the list.
- Move enables you to adjust the stacking order of the titles or footnotes.

FORMAT MENU

The Format menu lets you set a style for the graph. Styles that have been optimized for use with analytical graphs are included in this menu. These are Analysis, Default, Journal, Listing, and Statistical. The original style of the graph applied by the system is shown as StatGraphScheme.

The Graph Properties dialog box can be opened from this menu to adjust the overall properties of the graph, such as size and background color.

The Plot Properties or Annotation Properties dialog box can be used to customize the properties of the selected object. More information on these dialog boxes is provided later in this paper.
TOOLBAR
The graph toolbar shown in Figure 7 provides an alternate way to add graph objects or annotation objects to the graph. The available options are the same as in the Insert menu.

EDITING THE GRAPH
Suppose you want to edit the graph that has been opened in the ODS Graphics Editor. Figure 8 shows the Distance by Distance graph from PROC ROBUSTREG. You want to edit this graph as follows:

1. Change the title to “Analysis of Economy Growth.”
2. Add a footnote showing the year for the data used.
3. Move the legend from outside of the plot area to the lower-right corner of the plot area.
4. Highlight the outlier observation by adding emphasis to it.
5. Change the line pattern for the horizontal reference line.
6. Add a new title with the appropriate analysis parameters using Greek symbols and rich text formatting.
7. Change the style of the graph to Journal.
8. Change the width of the graph to 500 pixels.
9. Add a company logo.

1. CHANGE THE TITLE
   Double-click on the title to select it. Select all of the text and type the new title Analysis of Economy Growth as shown in Figure 9.

2. ADD FOOTNOTE
   Select Insert→Footnote from the menu, or click on the footnote toolbar button. The new footnote is added at
3. MOVE LEGEND

Once the footnote has been added, the bottom of the graph looks crowded. Because there is ample space available inside the plot area, move the legend into the graph in the lower-right corner.

Click with the right mouse button in the legend region and select Legend Properties. The Legend Properties dialog box is displayed as shown in Figure 11.

In the Position box, select Inside Plot Area. From the menu, select Bottom Right, and then select OK. The legend moves to its new location inside the plot area in the lower-right corner. Because there is no need to reserve space for the legend outside of the plot area, this space is recovered and a new graph layout is done.

4. HIGHLIGHT THE OUTLIER

The observation in the middle of the plot denoted by a red plus sign is an outlier. You want to label it with the name of the country it represents and highlight the marker to draw attention to it. To do this, use the oval and arrow annotation drawing tools from the toolbar as shown in Figure 12.

First, select the oval tool from the toolbar. Press the CTRL key, click on the observation, and drag out a circle. Using the CTRL key will create a circle that is centered on the mouse pointer location. The size of the circle depends on the dragged region.

Next, click with the right mouse button on the circle and select Annotation Properties. The Annotation Properties dialog box is displayed. In the Annotation Properties dialog box, change the outline color to red.

Select the arrow tool and drag an arrow from the desired point toward the circle. In the text box at the tail of the arrow, type Zambia. Click with the right mouse button and select Annotation Properties on the arrow. The Annotation Properties dialog box is displayed. Select the Text tab and set the text color to red.

The results are shown in Figure 13.

5. CHANGE LINE PATTERN

Change the line pattern of the horizontal reference line to a dashed pattern. Click with the right mouse button on the horizontal line and select Plot Properties as shown in Figure 14.

The Plot Properties dialog box is displayed as shown in Figure 15. The Plot Properties dialog box has three tabs: General, Plots, and Axes. Because you have clicked on a plot, the Plots tab is selected. Also, the selected plot is shown in the Plot menu. If the correct plot is not selected, you can change the plot using the menu. Also, if you missed the line when you clicked with the right mouse button, the dialog box comes up with the General tab selected. You can change to the Plots tab, and then select the plot.
Click on the Pattern menu and select one of the patterns. Click OK. The reference line changes to the selected pattern as shown in Figure 16.

6. ADD NEW TITLE WITH GREEK SYMBOLS

Add a second title to the graph. Include some analysis parameters using Greek symbols and subscripts. To begin this process, click on the title toolbar button as shown in Figure 17.

A new title is added under the existing title with the placeholder text Insert Text as shown in Figure 18.

Click with the right mouse button on the title and select Compose Rich Text. The rich text composer dialog box is displayed with the title text included.

Because this font supports the extended character set, the Greek character set is currently displayed in the character area. Compose the new title text by typing or clicking on the special characters in the character area. The menu in the upper-right corner provides Plain, Superscript, or Subscript as shown in Figure 19.

Click OK to get the second title as shown in Figure 20. Adding the second title reserves more space at the top of the graph and reduces the space available for the plot area.
7. CHANGE STYLE OF THE GRAPH
Select FormatÆStylesÆJournal to select the Gray Scale graph style.

8. CHANGE WIDTH OF GRAPH
Select FormatÆGraph Properties. The Graph Properties dialog box is displayed as shown in Figure 21. Change the width of the graph to 500.

Keep Aspect Ratio is currently selected. Changing the width to 500 also changes the height to 375 to maintain the current aspect ratio. To change the width independently from the height, deselect Keep Aspect Ratio.

9. ADD COMPANY LOGO
An image annotation can be added to display the company logo in the graph. Click on the image toolbar button as shown in Figure 22.

A file selection dialog box is displayed. You can select any .png image file. The image is initially displayed in the middle of the ODS Graphics Editor window. You can move the image.

RESULTS
The results of the nine steps are shown in Figure 23. The style is Journal, so all of the objects in the graph are in shades of gray. However, because you explicitly set the annotation color to red, it is retained. If you want the annotation color to be consistent with the style’s colors, do not set the annotation color to a specific color.

Figure 21

Figure 22

Figure 23
DATA LABEL MANAGEMENT

Often users have graphs that display data labels for each observation drawn in the graph as shown in Figure 24. When data labels run into each other, the graph uses a data-label collision-avoidance algorithm to move the data labels. This algorithm moves data labels away from other data labels, but can do so in an undesirable way. This can happen when there are too many labels on the graph. In the plot shown in Figure 24, the labels in the middle are too close together, and it is not clear which label belongs to which observation. In this situation, you might need to show only a few of the data labels, and you could hide the others.

The ODS Graphics Editor provides a tool to manage data labels. This tool is highlighted in Figure 24. After selecting this tool, you can see the available actions by clicking with the right mouse button. The top three actions can be performed on the selected observations, and the bottom two can be performed on all of the observations.

- Show Selected
- Show Only Selected
- Hide Selected
- Show All
- Hide All

In Figure 24, all of the observations that lie outside the confidence band are selected. You can click with the right mouse button and select Show Only Selected to display only the selected observations. Now, there might be more space to draw the data labels, so the data-label collision-avoidance algorithm is rerun to lay out the labels. The results are displayed in Figure 25.

CONCLUSION

The ODS Graphics Editor is the tool of choice for customizing ODS graphics output. The ODS Graphics Editor provides an intuitive and interactive interface to edit the visual attributes of the graphs without a need for any knowledge of template or procedure syntax. The ODS Graphics Editor does not allow you to change the data. The results can be saved in a file for incremental editing, or as an image file. You can copy the results directly to the system clipboard to include in other documents or presentations.

RECOMMENDED READING


CONTACT INFORMATION
Your comments and questions are valued and encouraged. Contact the author at:

Name: Sanjay Matange
Enterprise: SAS Institute
Address: R2108 SAS Campus Dr
City, State ZIP: Cary, NC 27512
Work Phone: (919) 531-6753
Fax: (919) 677-4444
E-mail: Sanjay.Matange@sas.com
Web:

SAS and all other SAS Institute Inc. product or service names are registered trademarks or trademarks of SAS Institute Inc. in the USA and other countries. ® indicates USA registration.
Other brand and product names are trademarks of their respective companies.