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ABSTRACT
New in Release 6.12, the VIEWTABLE window
provides a table-like interface for viewing and editing
SAS® data files.  This is a FRAME entry that displays
a data set in a Data Table object.  Version 6.11 of the
SAS System introduced Data Tables and Data Forms
as  new data entry classes in the SAS/AF® FRAME
product.  Major enhancements in Release 6.12 have
made VIEWTABLE a very acceptable alternative to
PROC FSVIEW for those users with graphics- capable
interfaces.  Two viewing modes are easily accessed,
Table View and Form View.  Moving between them is
easy, as is customizing the appearance of the columns.
The Import Wizard enables creation of SAS tables from
dBase, spreadsheets,  tab del im i ted or
comma-separated files.  The table just created by
VTIMPORT will display in the VIEWTABLE window for
further processing.  VTQUERY will display the result of
an interactive SQL interface. SAS data sets can be
searched, subsetted, sorted and saved to a new table
using VIEWTABLE.  This paper will provide insight into
this new product and display in online format some
useful features.

INTRODUCTION
In the wonderful land of SAS (at least since version
5.18), the ability to display and browse data using the
FSVIEW procedure (also known as PROC FSPRINT)
in SAS/FSP® software has been available.  This paper
is intended as a ‘how-to’ introduction to the new AF
VIEWTABLE window in the SAS System for Windows
95 Release 6.12, which provides users with another
way to create, view and edit SAS data sets interactively
in both a Table View and a Form View. (Note:
SAS/FSP software is required to edit or sort a table, or
to use the Form View mode.) Similarities and
differences between the two products will be
highlighted.  Finally the presentation will include a brief
overview of the new SAS System Viewer.  This freely
distributable application provides a method to view the
contents of SAS data sets and catalogs as well as text
files without using the SAS System.

The Data

A sample from Maryland Medicaid claims data,
containing 17 variables and 2509 observations will be
used for the examples.  This data set includes
information on procedures performed by physicians in
a variety of sites: hospitals, clinics, office, etc.  A
summary of the PROC CONTENTS is shown:

Variable Type Len Label

AGE Num 4 Age as of March 31

AID1 Num 4 Eligibility Category #1

BGDOS Num 5 Beginning date of service

COUNTY Num 4 County

DOSDIS Num 5 Date of discharge

DX2 Char 5 Secondary diagnosis

MCARE Char 1 Indicator for Medicare Coverage

PAY Num 8 Payment

PDX Char 5 Primary diagnosis

PLACE Num 4 Place of Service

PROCODE Char 5 Procedure code

RACE Num 4 Race

RECID Char 11 Record Identifier

SERVCD Num 4 MA service code

SEX Num 4 Gender

SPEC Num 4 Provider specialty

TYPE Char 4 Professional type

Opening the Windows
FSVIEW and VIEWTABLE windows can be opened
from the command line, from the Directory window or
from menu options.

   For example;

fsview sasuser.claims (opt ion)

         or vt sasuser.claims <argument> (opt ion) .  

Check the online help for a list of the invocation
arguments which can be used.

PROC FSVIEW can also be invoked by submitting the
program statements:

PROC FSVIEW DATA=SASUSER.CLAIMS;

RUN;
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The FSVIEW Table
PROC FSVIEW displays a SAS data set as a table of
columns and rows with the variable names as the
column labels.  Numeric variables are right justified
and character variables are left justified.  In SAS
version 6.11, the FSVIEW window was opened by the
menu selection Globals> Manage> Open table .  In
release 6.12 this selection will open the VIEWTABLE
window

The VIEWTABLE Data Table
As noted above, in release 6.12, the menu selection
Globals> Manage> Open table  displays the
VIEWTABLE window in New mode (the word New
appears in parentheses in the title bar). Begin creating
a new table or use File> Open  to select an existing
SAS data set as a table of columns and rows in the
(AF) VIEWTABLE window.  The Data Table can also
be displayed by double-clicking a SAS data set in the
Libraries window invoked by Globals> A ccess>
Display libraries .  When the LIBNAME window opens
type an S (select) beside the library and press Enter  to
open the DIR window.  Type an E (edit) beside the
table to open with ROW level edit access mode and
press Enter , or type a B (browse) beside the table to
open it in Browse mode.  Double clicking the mouse
button on the selection will also open the table.

Note again that the table can be opened in Edit mode
only if SAS/FSP is licensed.  

The first noticeable difference is the ‘spreadsheet’ grid
appearance and the larger choice of tool bar icons.  By
double-clicking on a column heading, a Column
Attributes window appears in which fonts, colors, and
other variable attributes can be manipulated.  Column
labels can be added and displayed (in contrast to the

FSVIEW window), and column width can be adjusted
by dragging.

VIEWTABLE provides the ability to switch easily
between the two viewing modes, Table View, and Form
View (this action is not available in the FSVIEW
window).  In Form View, if there are more variables
(columns) than will fit on one screen, the Data Form
will appear with dog-ears.

Help
The online documentation for the VIEWTABLE window
is very comprehensive. To access the extended help
system for VIEWTABLE, which provides detailed
procedures, explanations of all menu items, and
complete command syntax and descriptions, use any
of these options:
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• Select Help > Online d ocumentation > Base
SAS Documentation > VIEWTABLE  window from
the SAS pull-down menus.

• Select Help | Extended h elp  from the
VIEWTABLE pull-down menus.

• Use the VTHELP command from the VIEWTABLE
command line.

• Select the Help  button on the VIEWTABLE toolbar.

• To access help information for a dialog box in
VIEWTABLE, select the Help button on the dialog box.

• To access help in a VIEWTABLE dialog box, type
HELPMODE in the VIEWTABLE command line.
Press Enter .  Move the cursor over the dialog box,
and now it will be shaped like a question mark (?).
Click on the field, option, or list box for which help
is needed.. 

Pull Down Menu in the ViewTable Window

File Edit D ata View Customize

New Add Row W here Form View D ATAFORM
Entry....

Open... Copy Row Where C lear T able View M odel SCL...
Import Co mmit New Row H ide/Unhide Column  Names
Query D elete Row S ort For mView

Options>
Save Cancel Row Edits Ho ld TableView

Options>
Save As... F ind... Col umn Attributes
Export Rep eat Find T able Attributes
Like Edit Mode
Inclu de... Browse Mode
Print... R ow Level Edit

Access
Print  Setup T able Level Edit

Access
Print Prev iew
Cancel
End
Send...
Exit...

A Look Around the S creen
A good way to get acquainted with the new
VIEWTABLE application is to browse through the Pull-
Down and Pop-Up Menus that have been provided, and
to check out various handy Tool Bar  icons.

Pull-Down Menus 

In the VIEWTABLE menu bar the options shown in the
table above are available.
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Pop-Up Menus  

Throughout VIEWTABLE, there are helpful pop-up
menus available by clicking the right mouse button:

Table View Pop-Up

Column Specific Row/Cell

Colors... Clear Active Cell

Fonts... Clear Selections

Sort Print Setup...

Hide Print...

Hold Print Preview...

Column Description Add Row

Column Attributes... Copy Row

Commit New Row

Delete Row

Cancel Row Edits

Where

Where Clear

Edit Mode

 

Form View Pop-Up

Column Specific Row/Cell 

Colors... First Row

Fonts... Previous Row

Sort Next row

Hide Last Row

Column Description First Page

Column Attributes... Previous Page

Add Row

Copy Row

Commit New Row

Delete Row

Cancel Row Edits

Where

Where Clear

 Toolbar Options 

A toolbar or toolbox can be activated, which gives
access to buttons that perform an action in
VIEWTABLE when selected. Each button is an icon
that depicts its action. A descriptive label appears when
the cursor is placed over the button.  See Preferences
in the Options pull down menu. 

These activities can be performed by selecting toolbar
buttons:

Button Action

New Creates a new table

Open Opens an existing table

Save Saves changes to the open table

Print Specify printing options and print the
open table

Print Preview Previews the print output for the open
table

Add Row Adds a new row

Copy Row Copies the current row

Commit New
Row 

Saves current row changes

Cancel Row Edits Cancels current row edits

Delete Row Deletes the selected row. In New mode,
multiple rows can be selected for deletion.

Sort Ascending Sorts the table in ascending order
according to the values in the selected, or
highlighted, column(s)

Sort Descending Sorts the table in descending order
according to the values in the selected, or
highlighted, column(s)

Table View Changes the display to Table View mode

Form View Changes the display to Form View mode
(if  SAS/FSP software licensed)

Column Attributes Displays column attributes for the
selected column(s)

Table Attributes Displays table attributes for the open table

Edit Sets the table to Edit mode (if SAS/FSP
software licensed)

Browse Sets the table to Browse mode

Help Activates online help

Scrolling in Table View

To navigate through the table, use the scroll bars at the
right and bottom of the table, or the TOP, BOTTOM,
FORWARD, and BACKWARD commands.
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Selecting Columns in Table View

To select a single column in Table View, click on the
column label.  To select multiple columns, click
anywhere on a column and drag the mouse across
the columns to be selected. The columns are
highlighted as the mouse moves over them.
Alternatively, click on a single column, called the
anchor, then move the cursor to another column in
the table (either to the right or left of the anchor
column) press Shift, and click the mouse.  All the
columns are highlighted.  To select multiple
non-contiguous columns, move the cursor to each
column heading to be selected, press CTRL, then
click the mouse.  To select all columns in the data
table, click on the upper left box in the corner of the
table. To deselect all highlighted columns, select
Clear Selection from the pop-up menu, which is
accessed while the cursor is over one of the
currently highlighted columns, or select a cell that is
not in one of the currently highlighted columns.

Ordering Columns 

Ordering columns does not permanently affect the
order of the columns or data in  the table. It only
affects the view seen in the VIEWTABLE window.
To display columns in a particular order select
Data> Hide/Unhide .  When the Hide/Unhide dialog
box appears, select one column from the Displayed
list box using the mouse, and use the arrow buttons
under the Displayed list box to move the column up
or down in the list box.  By default, columns are
listed in the order they appear, left to right, in the
table. When a column is moved up in the list box, it
will appear  farther to the left in the table.
Alternatives: Within Table View, highlight the
contiguous column(s) to be moved; then use the
mouse button to drag and drop the column(s) onto
the column that will precede the moved columns. 

Resiz ing Rows and Columns 

The height of all rows, as well as the width of each
individual column can be adjusted in Table View.
To resize the height of all rows position the cursor
over the horizontal edge of any row label.

To resize the width of any column: position the
cursor along the right hand edge of any column
heading.  When the cursor changes appearance,
click and drag the cursor right or left to increase or
decrease the width of the column. The column
resizes to the width chosen when the cursor is
released.  

Holding Columns for Scrolling 

To hold certain columns in place during horizontal
scrolling through a table in Table View select Data>
Hold . A held column in a data table is similar to an ID
column in the FSVIEW window. To deselect a column,
select another column or click the Release  button.

Alternatives: Hold and release columns using the Hold
| Release  options on the pop-up menu or the HOLD
and RELEASE commands.

Searching the Data 

Select Edit> Find to search the data in the open table.
The Where expression dialog box opens, where the
search criteria can be entered.  In Form View, if the
value is found, the row where the value is found is
displayed.  In Table View, the row where the value is
found  becomes the top row in the display.  In either
view, if the value is not found, the last row of the table
is displayed, along with a message that the end of the
table was reached without a match.  To repeat the
search, select Edit> Repeat Find . If the pointer is on
the last  row of the table, the search begins at the
beginning of the table.  For example, if a search begun
halfway through the table reaches the bottom of the
table without finding a match, use Repeat Find   to
continue the search from the top of the table.

Alternative: Search the data using the FIND command.
The syntax used for the FIND command is the same as
used when building a where clause and must be
enclosed in quotes.

For example: find ‘procode= “ 93545” ‘

will find the next occurrence of where the column
procode is “93545” indicating a coronary angiography
procedure. If no value is passed in with the FIND
command, the Where dialog box opens, in which a
FIND string can be specified.

Subsetting Data 

Data can be subset in two ways:

• By viewing only certain columns
• By viewing only certain rows after applying a

WHERE expression. 

To view only certain columns, see Hiding and
Displaying Columns.  

To view only certain rows, select Data> Where  to open
the Where expression dialog box.  Specify criteria to
display a subset of data that meets those specific
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conditions.  If a where clause has already been
applied using the Where expression dialog box, and
more criteria need to be added to the existing
clause, reopen the Where expression dialog box.
The last WHERE clause will be displayed in the
dialog box, to allow continued selection of items and
further subset the data by adding an AND or an OR.
Alternatively, subset the data and clear the subset
using the Where  and Where Clear  options on the
pop-up menu. To clear a subset of rows: open the
Where expression dialog box then select the Reset
button and click OK. All rows in the table are
displayed.

Hiding and Displaying Columns 

Hiding or displaying columns does not affect the
columns or data stored in the table itself, but merely
affects what is displayed in the VIEWTABLE
window, as well as what is saved if the Save As
feature is used.  To hide or display one or more
columns in a table: Select Data> Hide/Unhide  to
reveal the Hide/Unhide dialog box. 

To hide a single column: double-click on the column
in the Displayed list box that is to be hidden, or
select the column from the Displayed list box, and
click the left single-arrow button between the two list
boxes. The column now appears in the Hidden list
box.

To hide multiple columns: drag the mouse over the
contiguous columns in the Displayed list. Click the
left single-arrow button between the two list boxes.
The columns selected now appear in the Hidden list
box. To hide all columns, click the left double-arrow
button between the two list boxes.  All columns now
appear in the Hidden list box. To unhide, or display,
certain columns in a table move the columns as
described above to the Displayed list box. Click the
right double-arrow button between the two list boxes
to display all columns. Click OK. All columns in the
table are displayed.  Alternatives: Hide/unhide one
or more columns using the Hide option on the
pop-up menu or the HIDE or COLUMNS
commands.

Displaying Column Labels or Column Names 

To display columns with labels or names in either
Table View mode or  Form View mode, select
View> Column Names  or Column Labels . (The
default is  Column Labels.) If no labels are available
and Column Labels is specified, then column names
are displayed instead.  Alternatively, display column
names or labels using the COLNAMES |
COLLABELS command.

Viewing and Changing Column Attributes 

The attributes of a column can be viewed, and certain
attributes can also be changed.  While viewing an
existing table, the label, the format/informat, the
foreground and/or background color of a column or its
label, the font of a column and/or its label can be
changed. These changes are reflected immediately in
the display when the Apply button is selected. To
“undo” changes requires resetting them. To view and
change column attributes for one or more columns:
select the column(s).  Select Data> Column
Attributes  (or request a pop-up while the cursor is over
a highlighted column).  The Column Attributes dialog
box appears. If a single column is selected, the dialog
box displays the attributes of the currently selected
column. If multiple columns have been selected, the
dialog box displays the attributes of the column
selected last. Only those tab pages and fields that are
appropriate for multiple columns are available.  Make
whatever changes are desired on the General, Color,
or Fonts tab  pages, and then select the Apply  button.
Any changes made to the attributes of a particular
column will be immediately displayed in VIEWTABLE.

If the color or font attributes set for a particular column,
are to be applied to other columns:

• Open the Column Attributes dialog box
• Select the columns to change, then select the

“model” column.
• Select Apply from the dialog box.

Viewing Table Attributes 

To view the table’s attributes, select Data> Table
Attributes .  The  Table Attributes dialog box opens,
providing a status for the open table.  It displays
read-only table attributes for existing tables,  which
cannot be altered. The Table Attributes dialog box
contains two tab pages:  General and Advanced. In
Table View, or double-click on upper left cell in the
table to open the Table Attributes dialog box (not
available in New mode).

Sorting Data 

VIEWTABLE uses the sorting program supported by
SAS for each particular  operating system. It sorts the
actual data in the table, not just the  display.  Note:  
The data in the table can be sorted only if SAS/FSP
has been licensed .  To sort the data, VIEWTABLE
must be able to gain Table Level edit access.
VIEWTABLE will try to gain this access temporarily in
order to perform the sort, regardless of how the current
open mode or access level options are set.  If access
fails, a message will display indicating that the table
cannot be sorted in place due to Table Level edit
access (or MEMBER lock) being unavailable.  If
VIEWTABLE cannot obtain Table Level edit access,
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the table can still be sorted by requesting that the
results be stored in a new table.

To sort the rows by one or more columns: select
Data> Sort  to display the Sort dialog box, and order
the rows of the table according to specific criteria for
the columns, for example, ascending or descending.
Select the column(s) on which to sort from the
Available list box. Click the right single arrow
located between the two list boxes. The column(s)
now appears in the Selected list box. To place the
columns in the desired sorting order, select a
column and move it up or down in the Selected list
box using the up or down arrow buttons located
below the list box. To indicate whether the
column(s) are to be sorted in ascending or
descending order, select a column in the Select list
box, then select Ascending or Descending from the
Selected Column Sort Order region. Ascending is
the default.

To save the sorted output to another file, select the
Save As  tab from the Sort dialog box.  Select the
down arrow beside the Path field to see a list of
currently  allocated librefs which can be selected.
However, if a directory has not been assigned a
libref, select the right arrow beside the Path field.
The Select Directory dialog box appears to allow
identification of the path. A libref will automatically
be assigned, making any SAS data sets or views in
that directory accessible immediately. Type the
name of the new table in the Table field on the Save
As tab page. Click OK. VIEWTABLE saves the
sorted output to the new table and opens this new
table in the display.

Printing 

Printing is only available from Table View mode
viewing either an existing table or creating a new
one. Set up and manage the list of printers by
selecting File> Print Setup  or by selecting the
Setup button on the Print dialog box. In either case,
the Print Setup dialog box appears where printers
can be set up and managed. To preview the printout
before printing, select File> Print P review . The
Print Preview dialog box appears, where output can
be viewed, two pages at once, and the size of the
preview output changed. The Print dialog box can
also be opened by selecting the Print button. 

To print an open table: select File> Print  to open
the Print dialog box appears, specify the printer, as
well as various printing options such as the printing
area and order.  Click OK. 

IMPORT/EXPORT FACILITY WIZARD

The Import Wizard is an interactive application that
creates SAS data sets from external file formats

such as dBase, spreadsheet, tab delimited, or comma-
separated files. When importing the external source
from within VIEWTABLE the table will display in the
VIEWTABLE. To import data from an external file
source select File> Import .  Follow the steps for
creating a SAS table from an external file. Make the
selections, name the external file and click the Next>
button.  Supply a name for the incoming data in the
MEMBER entry box and click the Finish  button.

The Export Wizard can be used to export SAS tables
to other external file formats, such as dBase, spread-
sheet, tab delimited, or comma-separated files. To
export data to an external file format Select File>
Export to open the Export Wizard. The table being
viewing in VIEWTABLE has automatically been
initialized as the SAS source data.  Or change the
source to a different table.  Otherwise, continue
stepping through each window to create the export file.
Choose from the following: DBF, EXCEL5, EXCEL4,
WK1, WK3, WK4, DLM, CSV, or TAB export file
formats.  Alternatively, define a special file format
using the External File Interface (EFI) facility.

As an example:  To transfer selected information from
a dBase file into a table for a Microsoft Word report
using the Import/Export Wizard.

• Import a dBase file, subset it in VIEWTABLE, and
save the subsetted data set with a new name. 

• Export the new file as a comma delimited file.
• In a Microsoft Word select Insert> File... and

choose the comma delimited file just exported. 
• Select all of the inserted text and choose Convert

Text to Table...  in the Table menu.  
• Et Voila!  That’s French for we’re back in Kansas.

For more information on the Import/Export Wizard,
open the wizard through VIEWTABLE and then access
its online help.
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SAS System viewer (for Windows 95 only)

This handy, free accessory is invoked from the
Windows Explorer by double-clicking or by clicking
the right mouse button on a SAS data set (.sd2) or
SAS catalog (.sc2) file icon.  

Download the latest version of the SAS System
Viewer (sview612.zip) from SAS Institute’s World
Wide Web site (http://www.sas.com) or by
anonymous FTP in the download section of the
Technical Support FTP site (ftp.sas.com) on the
internet: log on as anonymous  then enter your
email address  as the password.  When connected
enter:

cd /techsup/download/misc/additional/sasviewer/produc
tion

get sview612.zip

To disconnect, enter quit .

Use the SAS System Viewer to view SAS data sets
and SAS catalogs that have been created using the
SAS System Release 6.04 or later.  Also view SAS
files created by versions of the SAS System that run
on other platforms, and view and edit SAS
programs, text files, LST files, LOG files, and RTF
files. Columns and rows in grid displays can be
resized by grabbing and dragging the separator
between the headers, or just by double-clicking the
name or label. Print, sort and subset any SAS file in
the viewer, and copy the entire table, or column, row
and block selections to the clipboard.  Sort the view
of a SAS file by selecting a cell in a column and
then selecting a sort option from the View menu.

 Subset the data (using a WHERE clause) displayed
by the viewer by selecting Where from the View
menu (or pressing Ctrl-W).  Last but not least, text
anywhere in a SAS file can be found using regular
expressions by selecting Find from the Edit menu
(or pressing Ctrl-F).

CONCLUSION

The VIEWTABLE application and the FSVIEW
procedure each offer many useful features to simplify
data entry, query, editing, validation, display, and
retrieval.

So as to complete the metaphor of the title: the clever
wizards at SAS Institute have given us what we
wanted, an AF application to let us see our data,
although we actually had the ability all along without
really knowing it.
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