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Enhancing SAS  Output Tables with  WordPerfect®    ®

Hugh Geary, Neoprobe Corporation, Dublin, Ohio

Abstract

Creating tables from SAS output may involve use of
some rather detailed WordPerfect code.  Once the
ground has been broken by producing a few tables,
future tables can often be done with only modifications.

Titles can be put in large bold print, employ various
font styles and be underlined.  The body of the table
can be enclosed in an array of vertical and horizontal
lines.  Shading can be used for emphasis in various
elements of the array.  Superscripts can be used for
footnotes.

In general, tables can be produced by taking the
following steps.  First prepare the SAS output by
inserting tabs for creating columns and writing it to a
text file.  Next initiate a WordPerfect session and reset
defaults to your specific needs.  Then invoke
WordPerfect menus to create the table, border, a
heading with shading and shading for the array’s
diagonal elements.  Finally record these actions into a
macro.  It can be edited to make changes and additions
and can be replayed for similar text files.

This paper summarizes my experiences in learning to
use WordPerfect to customize a SAS generated table
and then building a WordPerfect macro to automate the
process.

Introduction

When numerous tables are produced for a project, it is be underlined.  These would be in effect for the whole
useful to have a standard convenient means of placing document, but highlighted text can be modified by the
emphasis on their salient features and optimizing their buttons or other pull-down menus as the need arises.
appearance.  WordPerfect is capable of performing  
these tasks.  In the subsequent discussion we will go In addition to selecting a font under format, you might
step by step through the process of building a featured also do the following:
table out of a table created by SAS.  Macros can be  
written for the various tables so that whenever the data
are revised and the SAS programs have been rerun, the
tables can be reproduced by rerunning the WordPerfect
macros.  All tables can then be collected into one file
and have the pages renumbered by WordPerfect. 

Preparation of the SAS
output data

The numbers that make up the rows and columns of the
table need to be separated by a tab.  An easy way to
insert tabs is to write the hexadecimal form of the tab,
‘09'x, in the output as it is being written by the SAS
program.  For example, the put statement that writes to

the output file can be written as follows:

   Put Id1 head. +(-1)‘09'x Z1  +(-1)‘09'x Z2 
 +(-1)‘09'x Z3;

or
 Put Id1 head. (Z1-Z3) (+(-1)‘09'x);

where head. is a format used to put character string
descriptors down the left side of the table and Zi,
i=1,2... are numbers.

Titles and footnotes should be positioned without
centering because centering, bolding, italicizing, setting
fonts and font size can be done more efficiently by
WordPerfect.

Document Initialization

Start a WordPerfect session by clicking on the
WordPerfect icon.  A blank document appears on the
screen accompanied by pull-down menus for fonts, font
sizes and text alignment as well as a number of buttons
such as bold, italic and underline to control the
appearance.  Bring in the SAS output text file by
clicking on FILE and specifying your file as input.

Clicking on format and then clicking on font displays a
large menu enabling you to set any one of these and
more for the whole document.  For example, from the
format menu you might choose Courier New in font
face, 10 in font size, and in Underline make spaces
blank so that spaces between underlined words won’t

  Format > Line > Spacing. 

(This means select the format menu, then the line
submenu from it and finally within the submenu, select
the spacing entry.) 

Set spacing to, say, 0.83.  Then OK.  Then do:

  Format > Margins.

Set top & right margins to 0.25 and the left and bottom
margins to 0.5.  Then OK.

The result for our example (in which the numbers are
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fictitious) is: Take the Tabular Column default.  Click on OK.  The

            TABLE A.1   Relative Shifts in

         Red Blood Cell Count (x1,000,000/mL.)

                     REFERENCE RANGE: (3.85 - 5.60)

     Baseline            Hospital Admission
- 0 + Missing Total

- 80 39 0 2 121
0 53 291 7 8 359
+ 1 10 6 0 17
Missing 4 10 2 5 21
Total 138 350 15 15 518
                           Stuart-Maxwell test:  p = 0.60

Title lines

For titles highlight whatever lines you wish to affect by
the pull-down menus or buttons.  Then click on Center
(in alignment) Bold, Italic and/or Underline.  Click to
open the font menu and click on the desired font name.
Do the same for font size.

        TABLE  A.1    Relative  Shifts  in

     Red  Blood  Cell  Count  (x1,000,000/mL.)

              REFERENCE RANGE: (3.85 - 5.60)

   Baseline            Hospital Admission
- 0 + Missing Total

- 80 39 0 2 121
0 53 291 7 8 359
+ 1 10 6 0 17
Missing 4 10 2 5 21
Total 138 350 15 15 518
                           Stuart-Maxwell test:  p = 0.60

Change the Tab Default

Place the pointer to the left of the first line of the table
and highlight the whole table, but on the last row do not
go beyond the last cell of the array.  Then select:

  Format > line > Tabset

The tabset menu will appear.  In settings put a check
mark in Repeat and enter 1.0 after the word, Every.
Click on Clear All (not Clear), next on Set and then
OK.  Without the Clear All, the tab would have its
default length which is only 5.

        TABLE  A.1    Relative  Shifts  in

     Red  Blood  Cell  Count  (x1,000,000/mL.)

              REFERENCE RANGE: (3.85 - 5.60)

   Baseline            Hospital Admission
- 0 + Missing Total

- 80 39 0 2 121
0 53 291 7 8 359
+ 1 10 6 0 17
Missing 4 10 2 5 21
Total 138 350 15 15 518
                      Stuart-Maxwell test:  p = 0.60

Create the Table  

Click to remove the highlighting (and to apply the last
action) and again highlight the table entries. From the
menu select: Then select Header Fill Column and click on Apply.

  Table > Create 
 (it should not prompt for # of columns.)

table framework should appear - with one number in
each box!

        TABLE  A.1    Relative  Shifts  in

     Red  Blood  Cell  Count  (x1,000,000/mL.)

              REFERENCE RANGE: (3.85 - 5.60)

   Baseline            Hospital Admission

- 0 + Missing Total

- 80 39 0 2 121

0 53 291 7 8 359

+ 1 10 6 0 17

Missing 4 10 2 5 21

Total 138 350 15 15 518

                      Stuart-Maxwell test:  p = 0.60

 
Align number entries by
decimal point  

Place the pointer in the first entry, A1 (i.e., Column A,
Row 1). Then select:

  Table > Format > Table

In Alignment/Justification choose Decimal Align, then
click in column width and type in 1.0.  In the Table
Position select From Left Edge and type in 1.25 and
OK.

        TABLE  A.1    Relative  Shifts  in

     Red  Blood  Cell  Count  (x1,000,000/mL.)

              REFERENCE RANGE: (3.85 - 5.60)

   Baseline            Hospital Admission
- 0 + Missing Total

- 80 39 0 2 121

0 53 291 7 8 359

+ 1 10 6 0 17

Missing 4 10 2 5 21

Total 138 350 15 15 518

                      Stuart-Maxwell test:  p = 0.60

Make Border and Center the
column A entries
 
Again place pointer in cell A1.  From the menu select:
. 
Table > Speed Format

Select  Table, Format and Column.  In Justification
select Center and OK. This performs centering for
Column A only.
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To modify row height select:

  Table > Format > Row.

In row height select fixed and set it to 0.26, say.

        TABLE  A.1    Relative  Shifts  in

     Red  Blood  Cell  Count  (x1,000,000/mL.)

              REFERENCE RANGE: (3.85 - 5.60)

   Baseline            Hospital Admission
- 0 + Missing Total

- 80 39 0 2 121

0 53 291 7 8 359

+ 1 10 6 0 17

Missing 4 10 2 5 21

Total 138 350 15 15 518

                      Stuart-Maxwell test:  p = 0.60

Center the col umn headings
in the row 1 entries

Highlight Row 1, then select:

  Table > Format > Cell.

In Justification/Justification select Center and OK.

      TABLE  A.1    Relative  Shifts  in

   Red  Blood  Cell  Count  (x1,000,000/mL.)

             REFERENCE RANGE: (3.85 - 5.60)

   Baseline            Hospital Admission
- 0 + Missing Total

- 80 39 0 2 121

0 53 291 7 8 359

+ 1 10 6 0 17

Missing 4 10 2 5 21

Total 138 350 15 15 518

                      Stuart-Maxwell test:  p = 0.60

Shade in the diagonal
entries  

Click in cell B2 (and repeat for C3, D4, E5 & F6.)
Select:

  Table > Lines/Fill,

then inside the cell fill box, click in the box in front of
Fill and hold down until you move the cursor to button
Fill (row 3, column 1), then release it. Click OK.

        TABLE  A.1    Relative  Shifts  in
  

     Red  Blood  Cell  Count  (x1,000,000/mL.)

              REFERENCE RANGE: (3.85 - 5.60)

   Baseline            Hospital Admission  

- 0 + Missing Total

- 80 39 0 2 121

0 53 291 7 8 359

+ 1 10 6 0 17

Missing 4 10 2 5 21

Total 138 350 15 15 518

                        Stuart-Maxwell test:  p = 0.60

Print the table.  
 
Instead of saving this result in your original text file
you may want to specify saving it in a .wpd type file.

H o w  to  create  a
superscript

Highlight the character(s) to be superscripted.  Then
select:

  Format > Font > Position 

and from this menu (3  level down) select Superscript.rd

Subscripts can be created here as well.
Also ®, © and other characters may be inserted by
invoking:
  
  Insert > Character

and clicking on one of a few hundred choices.
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How to record the above
actions into a WordPerfect
macro
 
The actions just executed by invoking menus generate
code which can then be saved and reused or replayed as
long as the input files contain the same type of data. 

To save this code have the file to be processed present
in the WordPerfect document window. Click on the
record macro button.  It will ask you to supply the
name of the macro for saving code to be generated by
the actions you are about to perform.  All of the actions
performed on the document will be recorded until you
click on the Stop button which will appear when the
recording session begins.

How to play a macro

Again have the file present in the WordPerfect
document window.  Position the cursor where it was
when you began recording. The upper left hand corner
is a good choice.  Click on the Play Macro button.  If
you have several pages of similar tables, the macro may
be invoked to run several times before stopping by
using the repeat option under Edit.  Select:

  Edit > Repeat

and fill in the number of times the macro should be
execute before stopping.
  
If you wish to change what has been stored it may be
easier to re-record the whole operation instead.
Nevertheless the macro may be edited.

How to edit a macro

Click on the edit macro button, supply the macro name
as prompted and the file containing the macro code will
be opened. A macro may be written from scratch, but
it is far easier to modify already recorded code.

Learning to write WordPerfect macro code can be done
by looking at recorded code and making simple changes
such as causing an action to be done a line earlier or
later, changing fonts or adding a title.  Manuals may
contain lists of hundreds of macro commands whose
names are almost self-explanatory but with little other
documentation.

After editing, click on the Options button.  It will
prompt you to save the macro if you have made any
changes and then allow you to close.

To cause each individual action to appear on the screen
as it is performed by the macro, include the display

command near the beginning.  The syntax is:

  Display (ON!) 

Display is a very helpful tool to reveal what the macro
is actually doing when it is not working properly, yet
impressive to watch when it is.

How to create procedures
within a macro to save
repeating code

Procedures can be introduced by supplying the
procedure and endproc statements, macro code for
some task in between and the call statement, for
example:

Procedure Titl4()
PosLineDown ()
PosLineDown ()
SelectLineDown ()
Font (Name: "Courier New Regular"; Family:
FamilyCourier!; Attributes: FontMatchNormal!;
Weight: 90; Width: WidthUnknown!; Source:
DRSFile!; Type: TrueType!; 
CharacterSet: FontMatchASCII!)
FontSize (FontSize: 13p)
AttributeAppearanceOn (Attrib: Bold!)
endproc
     ...other code...
Titl4()
     ...other code...

  The code for creating just the panel (or array)portion
of the table above can be put in a procedure so that
three panels identical in shape and form can all be put
on a single page.  The code for a title might be encoded
in a procedure for reuse as shown above.  My code for
the three-panel page through the use of procedures  is
shorter than the raw code generated by recording the
creation of one panel originally.

Conclusions
WordPerfect has numerous features which can be
incorporated into macros for automated processing of
tables generated by SAS programs.

Author:

Hugh Geary
Neoprobe Corporation
425 Metro Place North
Dublin, Ohio 43017

(614) 793-7500 ext 168 (voice)
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(614) 793-7520              (fax)
 hgeary@neoprobe.com(e-mail)

SAS is a registered trademark of SAS Institute, Inc., and
WordPerfect is a registered trademark of 1996 Corel Corporation

Limited, in the USA and other countries.  ® indicates USA
registration.
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